Increased latency between select APAC and EU locations

Incident Report for Teraswitch

Resolved

Traffic has been rerouted around the providers most affected by an undersea cable cut between EU and APAC.
Posted Oct 23, 2023 - 21:42 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 23, 2023 - 17:56 UTC
This incident affected: AMS1 - Amsterdam, Netherlands, DUB1 - Dublin, Ireland, FRA1 - Frankfurt, Germany, and SGP1 - Singapore.